WordPress Security Alert: WordPress 5.4.1 release

WordPress security alert: version 5.4.1 has been released, along with security updates for earlier branches as far back as 3.7.x.

WordPress 5.4.1 fixes seven security vulnerabilities. To keep your website secure, please make sure your WordPress installation is up to date. You can read more about the security issues that have been fixed in the WordPress announcement.

In most cases, WordPress will automatically update to the secure version on the branch installed. If you notice your website has not updated, or you aren’t sure, check in with your trusted web developer. Keeping WordPress up to date is the best way to keep your website secure.

Note to our clients: if your WordPress website is not secure, we will reach out to you to address it shortly.

Website security protects your visitors and your reputation. You can improve your website’s security and decrease your website’s risk factors by keeping your WordPress site, themes, and plugins updated.

You can upgrade WordPress yourself. See how to do so without putting your site and its contents at risk.

If you’d like to:

  • Be sure your website is always secure and up to date
  • Spend your time on your business’s or organization’s main mission worry-free

Check out our hassle-free security packages and ask for a quote.

Like it? Share it!

FacebooktwitterredditlinkedinmailFacebooktwitterredditlinkedinmail

Alisa Cognard

Alisa was one of the first team members to join Red Earth Design, Inc. in early 2004. From data entry, she progressed to MySQL database manipulation and PHP coding. Alisa is responsible for all kinds of odds and ends: installing new websites, adding features to them, programming databases, PHP coding, website troubleshooting, website security, and organizational tasks for Red Earth Design.

Leave a Reply

Your email address will not be published. Required fields are marked *