WordPress Security: WordPress 5.7.1

WordPress 5.7.1 patches two security vulnerabilities, so if your website has not automatically upgraded to a secure version, please upgrade your WordPress installation as soon as possible.

Security Alert: Adobe Flash Reaches End of Life

Adobe Flash will no longer receive security updates, and starting January 12, 2021, Flash content will be blocked. What does this mean for you?

WordPress Security: WordPress 5.5.2 and 5.5.3 release

WordPress 5.4.2 patches six security vulnerabilities, so if your website has not automatically upgraded to a secure version, please upgrade your WordPress installation as soon as possible.

WordPress Security Alert: WordPress 5.4.2 release

WordPress 5.4.2 patches six security vulnerabilities, so if your website has not automatically upgraded to a secure version, please upgrade your WordPress installation as soon as possible.

WordPress Security Alert: WordPress 5.4.1 release

WordPress 5.4.1 patches seven security vulnerabilities, so if your website has not automatically upgraded to a secure version, please upgrade your WordPress installation as soon as possible.

WordPress Plugin Security Alert: Ultimate Addons for Beaver Builder and Ultimate Addons for Elementor

Ultimate Addons for Beaver Builder and Ultimate Addons for Elementor, plugins used to add extra features to the Beaver Builder or Elementor page builders, have an important security update available. 

WordPress Security Alert: WordPress 5.3.1 release

WordPress 5.3.1 patches four security vulnerabilities, so if your website has not automatically upgraded to a secure version, please upgrade your WordPress installation as soon as possible.

WordPress Security Alert: WordPress 5.2.4 release

WordPress 5.2.4 patches six security vulnerabilities, so if your website has not automatically upgraded to a secure version, please upgrade your WordPress installation as soon as possible.

WordPress Security Alert: WordPress 5.2.3 release

WordPress 5.2.3 fixes a number of security vulnerabilities, so if your website has not automatically upgraded to a secure version, please upgrade your WordPress installation as soon as possible.

Security Alert: Firefox Vulnerability in versions below 67.0.3

If you use Firefox, be sure you’re using the latest version. Firefox version 67.0.3 patches an actively exploited zero-day vulnerability.